Написать программу для нахождения суммы чёрных элементов массива не оканчивающихся на ноль. ИНФОРМАТИКИ ПРОШУ!!!!МНОГО БАЛЛОВ
gfhjkmgfhjkm20:
А какие элементы массива считаются чёрными? )
Ответы на вопрос
Ответил avion321321
0
Ответ:
const Sz = 10000;
var
a: array [1..Sz] of integer;
N: integer;
i: integer;
sum: integer;
begin
sum := 0;
write('Введите количество элементов в массиве: ');
readln(N);
write('Введите элементы массива: ');
for i:=1 to N do
begin
read(a[i]);
if (a[i] mod 2 = 0) then
begin
if (a[i] mod 10 <> 0) then
begin
sum := sum + a[i];
end;
end;
end;
write('Сумма элементов: ', sum);
end.
Новые вопросы
Русский язык,
2 года назад
Окружающий мир,
2 года назад
Математика,
2 года назад
Информатика,
2 года назад
География,
8 лет назад
Математика,
8 лет назад