Информатика, вопрос задал honorgg77 , 7 лет назад

Написать программу для Массива ( C# ):
П1. Дан массив целых чисел из n элементов, заполненный случайным образом числами из промежутка [-10,20]. Определить, есть ли в данном массиве положительные элементы, делящиеся на заданное число k

Ответы на вопрос

Ответил ЯковПервый
0

//Для проверки результата вывел массив на экран

using System;

namespace App1

{

   class Program

   {

       private static void Main()

       {

           const int x = -10;

           const int y = 20;

           int n, k;

           Console.Write("Enter n: "); n = int.Parse(Console.ReadLine());

           Console.Write("Enter k: "); k = int.Parse(Console.ReadLine());

           Console.WriteLine($"{Environment.NewLine}Array:");

           int counter = 0;

           int[] array = new int[n];

           Random rand = new Random();

           for (int i = 0; i < array.Length; i++)

           {

               array[i] = rand.Next(x, y + 1);

               if (array[i] > 0 && array[i] % k == 0) { counter++; }

               Console.WriteLine($"{i + 1}. {array[i]}");

           }

           Console.Write(Environment.NewLine);

           if (counter > 0) { Console.WriteLine($"В массиве {counter} элементов, соответствующих заданному условию."); }

           else { Console.WriteLine("В массиве нет элементов, соответствующих заданному условию."); }

           Console.ReadKey();

       }

   }

}

Приложения:
Новые вопросы