Информатика, вопрос задал uchalisgt , 7 лет назад

Написать программу для извлечения квадратного корня из длинного числа

Ответы на вопрос

Ответил utis
0

program ncp;

var

i,a : integer;

k,f: real;

begin

  f := 1;

  readln(a);

  for i := 2 to a do

  f := f *i;

k := sqrt(f);

 write(k);

end.  

Ответил uchalisgt
0
Ну например 100!=1*2*3*....**99*100, число содержит более 100 цифр
Ответил uchalisgt
0
Нет, нужно два длинных числа( в записи которых 100 цифр, например) и их надо перемножить
Новые вопросы