Информатика, вопрос задал svetabutko , 9 лет назад

Написать программу:
Даны длины сторон треугольника a,b,c. Является ли он прямоугольным?

Ответы на вопрос

Ответил 65536
0
var a,b,c,t:real;
begin
readln(a,b,c);
if b>a then begin
  t:=a;
  a:=b;
  b:=t;
end;
if c>a then begin
  t:=a;
  a:=c;
  c:=t;
end;
if (a*a=b*b+c*c) then writeln('Треугольник прямоугольный') else writeln('Треугольник не прямоугольный');
end.

Новые вопросы