Написать программу :
Даны 3 переменные. Поменять значения переменных по следующей схеме:
a=c, b=a, c=b. помогите, пожалуйста, в программе PascalABC, информатика
Ответы на вопрос
Ответил Аноним
0
Var
A,B,C:real;
Begin
Write('A = ');ReadLn(A);
Write('B = ');ReadLn(B);
Write('C = ');ReadLn(C);
A:=C;
B:=A;
C:=B;
WriteLn('A = ',A);
WriteLn('B = ',B);
WriteLn('C = ',C);
End.
Если имеется ввиду, поменять местами переменные в заданном порядке, то вот:
Var
A,B,C:real;
Begin
Write('A = ');ReadLn(A);
Write('B = ');ReadLn(B);
Write('C = ');ReadLn(C);
Swap(A,C);
Swap(B,A);
Swap(C,B);
WriteLn('A = ',A);
WriteLn('B = ',B);
WriteLn('C = ',C);
End.
A,B,C:real;
Begin
Write('A = ');ReadLn(A);
Write('B = ');ReadLn(B);
Write('C = ');ReadLn(C);
A:=C;
B:=A;
C:=B;
WriteLn('A = ',A);
WriteLn('B = ',B);
WriteLn('C = ',C);
End.
Если имеется ввиду, поменять местами переменные в заданном порядке, то вот:
Var
A,B,C:real;
Begin
Write('A = ');ReadLn(A);
Write('B = ');ReadLn(B);
Write('C = ');ReadLn(C);
Swap(A,C);
Swap(B,A);
Swap(C,B);
WriteLn('A = ',A);
WriteLn('B = ',B);
WriteLn('C = ',C);
End.
Ответил Аноним
0
В каком Паскале проверяете? Turbo? Free? ABC? ABC.net?
Ответил Mitya111
0
Извините, я перепутал одиночную кавычку с двойной. все заработало, большое спасибо!!!
Новые вопросы
Геометрия,
2 года назад
География,
2 года назад
Алгебра,
8 лет назад
Математика,
8 лет назад
Математика,
9 лет назад