Информатика, вопрос задал БлОнДиНкО7 , 2 года назад

Написать программу. Даны 2 числа a и b. Найти среднее арифметическое всех чисел кратных 3 из интервала [a,b].

Ответы на вопрос

Ответил vladik1603
0
var
  i, j, a, b: integer;
  s: real;
begin
  write('Введите a: '); readln(a);
  write('Введите b: '); readln(b);
  for i := a to b do
    if (i mod 3) = 0 then
    begin
      s := s + i;
      inc(j);
    end;
  s := s / j;
  writeln('Ответ: ', s);
end.
Новые вопросы