Информатика, вопрос задал bakishev03 , 7 лет назад

Написать программу. Даны 10 оценок ученика по математике. Найти средний бал. Исправить оценки, которые <=3 на бал выше. Вывести все 10 оценок на экран.

Ответы на вопрос

Ответил VashYchiteLGoda
0

java:

import java.util.Random;

int [] ocenki = new int [10];

Random rand = new Random ();

for( int i = 0; i < ocenki.length; i++){

   ocenki[i] = rand.nextInt(3+1) + 1;

   if (ocenki[i] <= 3) ocenki[i] = ocenki[i] + 1;

   System.out.print(ocenki[i] + "t");

}

Новые вопросы