Информатика, вопрос задал PIXBL , 9 лет назад

Написать программу.Дано четырехзначное число.Определить , равен ли квадрат первой цифры кубу третьей цифры этого числа.

Ответы на вопрос

Ответил vladmor
0
Только один вариант дает положительный результат. Когда первая цифра числа и третья равны 1

//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var a:integer;
begin
  write('Введите число ');readln(a);
  if ((a div 1000)=1)and  ((a div 10 mod 10)*(a div 10 mod 10)= 1)then
  writeln('квадрат первой цифры равен кубу третьей цифры этого числа')
  else
   writeln('квадрат первой цифры не равен кубу третьей цифры этого числа')
end.

Тест №1
Введите число 1214
квадрат первой цифры равен кубу третьей цифры этого числа

Тест №2
Введите число 2237
квадрат первой цифры не равен кубу третьей цифры этого числа



Новые вопросы