Информатика, вопрос задал sermilov889 , 2 года назад

Написать программу.
Дан список целых чисел. Найдите все числа 30 и замените их на '*'. Проверить все возможные варианты:
- если в списке есть числа 30
- если в списке нет чисел 30


ПРОШУ ПОМОГИТЕ

Ответы на вопрос

Ответил Papapapapapam
1

l = list(map(int, input().split()))

l1 = []

for i in l:

   if i==30:

       l1.append('*')

   else:

       l1.append(i)

print(l1)


sermilov889: Спасибо огромное
Papapapapapam: ничего не нужно объяснять?
sermilov889: Ну если не сложно, то был бы очень признателен
Papapapapapam: всю программу?
sermilov889: Как хочешь
Papapapapapam: 1. input().split() принимает строку с значениями чисел, и разбивает ее на список с элементами в строковом типе данных, map(int( же превращает элементы этого списка в целочисленный тип. 2. создаем список l1 3. циклом проходимся по списку l: если l = 30, то в l2 добавляем *, если не 30, то само число. 3. выводим список l1
sermilov889: Спасибо!!!!
Papapapapapam: не за что)
Новые вопросы