Написать программу c++ cin cout
Условие
Дан массив из n элементов (n<100) , определите, у какого количества элементов значение и номер в массиве совпали (нумерация элементов ведется с единицы).
Входные данные выходные данные
3
1 2 1 2
abg91771:
да
Ответы на вопрос
Ответил fewfwemofokweko
2
#include <iostream>
using namespace std;
int main() {
int N, count = 0;
cin >> N;
int* arr = new int[N];
for(int i = 0; i<N; ++i) {
cin >> arr[i];
if(arr[i] == i+1)
++count;
}
cout << count;
}
Новые вопросы