Написать программу
4. Компьютер перебирает четные числа до тех пор, пока сума их квадратов не превысит S. Чему равна сумма квадратов?
Подсказка:
Начальное значение переменной цикла – 2. Шаг изменения – 2 (перебираем четные числа).
Считаем сумму квадратов до тех пор пока она меньше или равна S.
Вывод на экран :
Результат:
s =
Тест 1:
Исходные данные:
s = 24
Результат:
s =56
Тест 2:
Исходные данные:
s = 85
Результат:
s =120
Ответы на вопрос
Ответил neznayka22
0
program pr_1;
var i,s,sq:integer;
begin
readln(s);
i:=2;
while sq<=s do
begin
sq:=sq+sqr(i);
i:=i+2;
end;
writeln('sq=',sq);
end.
var i,s,sq:integer;
begin
readln(s);
i:=2;
while sq<=s do
begin
sq:=sq+sqr(i);
i:=i+2;
end;
writeln('sq=',sq);
end.
Новые вопросы
Алгебра,
2 года назад
Физика,
2 года назад
Биология,
9 лет назад
Химия,
9 лет назад
Литература,
10 лет назад