Написать на С++
Составьте программу для нахождения всех автоморфных чисел в
отрезке [m,n]. Автоморфным называется целое число, запись которого
совпадает с последними цифрами его квадрата. Например:
5^2=25
6^2=36
25^2=625
Ответы на вопрос
Ответил Guerrino
3
#include <iostream>
using namespace std;
int
main ()
{
int k, m, n, i, p;
cin >> m >> n;
for (i = m; i <= n; i++)
{
p = i;
k = i * i - i;
while (k % 10 == 0 && p > 0)
{
k = k / 10;
p = p / 10;
};
if (p == 0)
cout << i << " ";
};
return 0;
}
Новые вопросы
Химия,
1 год назад
Алгебра,
1 год назад
Информатика,
2 года назад
Химия,
2 года назад
Английский язык,
7 лет назад