Информатика, вопрос задал bluberry12 , 7 лет назад

Написать на Питоне не паскаль 2) Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 6 и оканчивающихся на 8. Программа получает на вход количество чисел в последовательности, а затем сами числа. Программа должна вывести одно число: количество чисел, кратных 3 и оканчивающихся на 2.
3) Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Программа должна вывести одно число — сумму чисел, кратных 5.

Ответы на вопрос

Ответил FANTSCR1N
1

# 1

n = int(input('Кол-во чисел: '))

count = 0

for i in range(n):

   num = int(input('Введите число: '))

   if (num % 6 == 0) and (num % 10 == 8):

       count += 1

print('1) Кол-во чисел( кратных 6 и оканчивающихся на 8 ):', count, '\n')

# 2

n = int(input('Кол-во чисел: '))

count = 0

for i in range(n):

   num = int(input('Введите число: '))

   if (num % 3 == 0) and (num % 10 == 2):

       count += 1

print('2) Кол-во чисел( кратных 3 и оканчивающихся на 2 ):', count, '\n')

# 3

n = int(input('Кол-во чисел: '))

s = 0

for i in range(n):

   num = int(input('Введите число: '))

   if (num % 5 == 0):

       s += num

print('3) Сумма чисел кратных 5:', s)

Новые вопросы