Информатика, вопрос задал 77d05 , 1 год назад

Написать на Pascal abc

Всем известно, что многие олимпиадные задачи начинаются со слов «Всем известно». Но мало кто знает, что начинающему программисту Паше такие задачи меньше всего нравятся. Потому что обычно после слов «всем известно» описывается такой факт, о котором он даже не догадывался. После очередной подобной задачи Паша решил проверить, а действительно ли всем известно, что сумма первых N нечетных чисел равняется N2:

Для этого Паша провел опрос всех людей, попавшихся ему под руку в известной социальной сети. Результаты опроса он записал в текстовый файл. Он ставил цифру один, если человеку был действительно известен данный факт, в противном случае в файл записывался нуль. Все было хорошо, пока Паша не открыл файл и не ужаснулся, увидев длинную последовательность из единичек. Как же он теперь будет искать среди них нули?

Уже всем известно, что Паша – начинающий программист, поэтому для обработки результатов исследования он обратился к вам за помощью.

Входные данные
Входной файл INPUT.TXT содержит непустую последовательность из нулей и единиц. Длина последовательности не превышает 10^4.


Выходные данные
В выходной файл OUTPUT.TXT выведите слово «YES», если факт был известен всем опрошенным людям, и слово "NO" в противном случае.

Примеры
№ INPUT.TXT OUTPUT.TXT
1 11111101010011. NO
2 11 YES

Ответы на вопрос

Ответил petyaGavrikov
1

Ответ:

var t1,t2:text; c:char; f:boolean;

begin

assign(t1,'INPUT.TXT');

reset(t1);

assign(t2,'OUTPUT.TXT');

rewrite(t2);

f:=true;

while not eof(t1) and f do

begin

read(t1,c);

f:=f and (c='1');

end;

if f then writeln(t2,'YES')

else writeln(t2,'NO');

close(t1);

close(t2);

end.


77d05: Спасибо большое
77d05: Можете пожалуйста пояснить что такое eof?
77d05: Просто я ещё не проходил
petyaGavrikov: функция, проверяющая конец файла (end of file).
Новые вопросы