Информатика, вопрос задал Ivanmalugin , 1 год назад

Написать алгоритм, написать программу, ПОЖАЛУЙСТА ОЧЕНЬ СРОЧНО

Приложения:

Ответы на вопрос

Ответил lontrid
1

На Python

x = int(input())

if 5 > x > 0:

   y = 2 * x

elif x == 0:

   y = 0

elif -5 < x < 0:

  y = 3 * x

print(y)

На Pascal

var x, y: integer;

begin

readln(x);

y := 0;

if (x > 0) and (x < 5) then

 y := 2 * x;

if x = 0 then

 y := 0;

if (x < 0) and (x > -5) then

 y := 3 * x;

writeln(y);

end.


Ivanmalugin: Входные выходные данные знаете?
Ivanmalugin: Это паскаль должен быть
lontrid: Изменил ответ, теперь есть и на Python, и на Pascal.
lontrid: Входные данные, наверное, могут быть любыми.
lontrid: Хотя, как я понял, по условию, x лежит в (-5; 5)
Новые вопросы