Награда 50 баллов!!!
Нужно написать программу в паскаль. Попадает ли точка введения пользователем (её координаты) в выделенную область.

Ответы на вопрос
Ответ:
const
a = 10;
b = 6;
R = 8;
var
x, y : real;
begin
readln(x, y);
if // Верхняя заштрихованная область
(((x>=0) and (x=<a)) and ((y>=0) and (y<=b)) and (sqr(x)+sqr(y)>=sqr(R)))
or
// Нижняя заштрихованная область
((x<=0) and ((y<=0) and (y>=-b)) and (sqr(x)+sqr(y)<=sqr(R)))
then writeln('Да')
else writeln('Нет');
end.
Объяснение:
попробуй вот так, извини если не получилось
===== PascalABC.NET =====
begin
var (x, y) := ReadReal2('Введи координаты точки:');
if x.InRange(-2, 6) and y.InRange(-2, 6) and
not ((x * x + y * y <= 2) or
((x * x + y * y >= 4) and ((x * x + y * y <= 6) and
((x > 0) and (y < 0))))) then
Print('Попадает')
else
Print('Не попадает')
end.