НАДО РЕШИТЬ ДВУМЕРНЫМ МАССИВОМ! Даны два числа n и m. Создайте двумерный массив [n][m] и заполните его по следующим правилам: Числа, стоящие в строке 0 или в столбце 0 равны 1 (A[0][j]=1, A[i][0]=1). Для всех остальных элементов массива A[i][j]=A[i-1][j]+A[i][j-1], то есть каждый элемент равен сумме двух элементов, стоящих слева и сверху от него.
Входные данные
Программа получает на вход два числа n и m.
Выходные данные
Выведите данный массив.
Примеры
входные данные
3 3
выходные данные
1 1 1 1 2 3 1 3 6
Ответы на вопрос
Ответил Аноним
0
Const
N = 3;
M = 4;
Var
A:array[0..N-1,0..M-1] of integer;
i,j,k:integer;
Begin
For i:= 0 to N-1 do
For j:= 0 to M-1 do
if i*j = 0 then A[i,j]:=1;
if M>N then k:=M
else k:=N;
For k:= 1 to k-1 do
For i:= 1 to N-1 do
For j:= 1 to M-1 do
if (i = k)or(j = k) then
A[i,j]:=A[i-1,j]+A[i,j-1];
For i:= 0 to N-1 do
For j:= 0 to M-1 do
Write(A[i,j],' ');
End.
N = 3;
M = 4;
Var
A:array[0..N-1,0..M-1] of integer;
i,j,k:integer;
Begin
For i:= 0 to N-1 do
For j:= 0 to M-1 do
if i*j = 0 then A[i,j]:=1;
if M>N then k:=M
else k:=N;
For k:= 1 to k-1 do
For i:= 1 to N-1 do
For j:= 1 to M-1 do
if (i = k)or(j = k) then
A[i,j]:=A[i-1,j]+A[i,j-1];
For i:= 0 to N-1 do
For j:= 0 to M-1 do
Write(A[i,j],' ');
End.
Новые вопросы
Математика,
2 года назад
Алгебра,
2 года назад
История,
8 лет назад
Литература,
8 лет назад
Математика,
9 лет назад