Надо написать программу на Паскале, без массивов.
Дано натуральное число. Определить, сколько раз у этого числа встречается минимальная цифра. (Например, при вводе числа 2618319, на экране должно быть "2").
Ответы на вопрос
Ответил PopCop312
0
var a, k, count: integer;
begin
readln(a);
k:=a mod 10;
a:=a div 10;
count:=1;
while(a<>0) do begin
if(a mod 10 = k) then count+=1;
if(a mod 10 < k) then begin
k:=a mod 10;
count:=1;
end;
a:=a div 10;
end;
writeln(count);
end.
begin
readln(a);
k:=a mod 10;
a:=a div 10;
count:=1;
while(a<>0) do begin
if(a mod 10 = k) then count+=1;
if(a mod 10 < k) then begin
k:=a mod 10;
count:=1;
end;
a:=a div 10;
end;
writeln(count);
end.
Ответил Аноним
0
var
s:string;
c:char;
i,k:integer;
begin
Write('Введите число: '); Readln(s);
c:=s[1]; k:=1;
for i:=2 to length(s) do
if s[i]=c then Inc(k)
else if s[i]<c then begin c:=s[i]; k:=1 end;
Writeln('Наименьшая цифра ',c,' встретилась ',k,' раз(а)')
end.
Тестовое решение:
Введите число: 3141592653589793
Наименьшая цифра 1 встретилась 2 раз(а)
s:string;
c:char;
i,k:integer;
begin
Write('Введите число: '); Readln(s);
c:=s[1]; k:=1;
for i:=2 to length(s) do
if s[i]=c then Inc(k)
else if s[i]<c then begin c:=s[i]; k:=1 end;
Writeln('Наименьшая цифра ',c,' встретилась ',k,' раз(а)')
end.
Тестовое решение:
Введите число: 3141592653589793
Наименьшая цифра 1 встретилась 2 раз(а)
Новые вопросы
Английский язык,
2 года назад
Информатика,
2 года назад
Обществознание,
9 лет назад
Математика,
9 лет назад
Математика,
10 лет назад
Алгебра,
10 лет назад