Информатика, вопрос задал letsplaynik42 , 1 год назад

Надо написать программу которая по заданному числу n находит два числа- x и y разность квадратов которых равна n

Ответы на вопрос

Ответил MrMaks1096
0

Ответ:

Программа запускалась в PascalABC.NET

var x,y,n: integer;

begin

 writeln(' Введите n');

 readln(n);

 for x:=1 to 100 do

   for y:=1 to 100 do

     if sqr(x)-sqr(y)=n then

       begin

         writeln(x,' ',y);

         exit;

       end;

end.

Объяснение:

Приложения:
Новые вопросы