Информатика, вопрос задал fadeev2913 , 2 года назад

Надо написать программу для решения этой задачи.
На языке Python 3.7.2

Дана последовательность из n (1≤n≤105) чисел ai (1≤ai≤1012) и q запросов (1≤q≤105). Каждый запрос предстает собой число pi (1≤pi≤1012).


Задача состоит в том, чтобы на каждый запрос вывести ответ - входит ли pi в исходную последовательность.


Входные данные

В первой строчке задается число n (1≤n≤105) и количество запросов q (1≤q≤105). Далее идут n чисел ai (1≤ai≤1012). Далее записаны q запросов pi (1≤pi≤1012).


Выходные данные

Вывести q ответов на запросы: на i-й запрос вывести ответ - «Yes», если pi содержится в исходной последовательности и «No» в остальных случаях)


Пример

входные данныеСкопировать

8 5

1 2 4 9 7 2 3 8

1

10

3

8

11

выходные данныеСкопировать

Yes

No

Yes

Yes

No

Ответы на вопрос

Ответил lofelynafa906
2

Ответ:

n=int(input("Введите число n: "))

while n < 1 and n > 105:

   n=int(input("Введите число n: "))

q=int(input("Введите число q: "))

while q < 1 and q > 105:

   q=int(input("Введите число q: "))

check='No'

a=[0]*n

for i in range(n):

   a[i]=int(input())

b=[0]*q

for j in range(q):

   b[j]=int(input())

for x in range(q):

   for y in range(n):

       if b[x]==a[y]:

           check='Yes'

           break

       else:

           check='No'

   print(check)

Объяснение:

Табуляцию сохраняем

Новые вопросы