Информатика, вопрос задал goodlike8279 , 1 год назад

Надо на c++ написать программу которая задаёт случайное число и его надо угадать. Делать надо с помощью Switch case

Ответы на вопрос

Ответил ssdMan
0

Ответ:

#include <iostream>

#include <cstdlib>

#include <ctime>

using namespace std;

int main() {

   int secret, guess;

   srand(time(0)); // Инициализация генератора случайных чисел на основе текущего времени

   secret = rand() % 100 + 1; // Генерация случайного числа от 1 до 100

   cout << "Добро пожаловать в игру угадай число!" << endl;

   cout << "Я загадал число от 1 до 100. Угадайте его." << endl;

   do {

       cin >> guess;

       switch(guess) {

           case 0:

               cout << "Выход из игры." << endl;

               return 0;

           case 1 ... 50:

               cout << "Слишком маленькое число. Попробуйте еще раз." << endl;

               break;

           case 51 ... 100:

               cout << "Слишком большое число. Попробуйте еще раз." << endl;

               break;

           default:

               cout << "Некорректный ввод. Попробуйте еще раз." << endl;

               break;

       }

   } while (guess != secret);

   cout << "Поздравляем! Вы угадали число " << secret << "!" << endl;

   return 0;

}

Объяснение:

У меня от 1 до 100 только получилось

Вроде должно работать так ( прости если код не работает )


ssdMan: switch case вроде используется
goodlike8279: У меня в программе эти три точки после 1 и 51 выводит красным
Новые вопросы