Информатика, вопрос задал coolkate1 , 7 лет назад

На языке си напишите программу: С клавиатуры вводятся натуральное m и действительное x. Найти сумму (прикреплено). Если можно, то с пояснениями

Приложения:

Ответы на вопрос

Ответил restIess
1

/*Объяснять тут нечего, если у тебя есть понимание языка.

Отдельно пишем функцию для нахождения факториала, а затем просто с помощью цикла считаем сумму.

*/

#include <stdio.h>

#include <math.h>

int factor(int N) {

int F = 1;

for (int i = 2; i <= N; i++)

 F *= i;

return F;

}

int main()

{

int m;

double x, _sum = 1.0;

scanf_s("%i %lf", &m, &x);

for (int i = 2; i <= 2 * m; i += 2) {

 _sum += pow(x, i) / factor(i);

}

printf("%lf", _sum);

return 0;

}

Новые вопросы