Информатика, вопрос задал tanyalove23 , 9 лет назад

На языке СИ. Напишите программу, которая получает два целых числа A и B (0 < A < B) и выводит квадраты всех натуральных чисел в интервале от A до B.
Пример:
Введите два целых числа:
10 12
10*10=100
11*11=121
12*12=144

Ответы на вопрос

Ответил timaben10
0
#include <iostream>
#include <conio.h>
using namespace std;

int main()
{
    setlocale(LC_ALL,"Russian");
    unsigned long long A,B;
    cout << "Введите A(Начало) и B(Конец):t";
    cin >> A >> B;
    if (A>0)
        for (unsigned long long i=A; i<=B; i++)
            cout << i << "t - t" << i*i << endl;
    else
    {
        cout << "Ошибка!";
        _getch();
        return -1;
    }
    _getch();
    return 0;
}

P.S. Это моя старая программа на C++, ПИСАЛ ЕЁ ДАВНО, использовал Microsoft Visual C++ 2010.


Новые вопросы