На языке С или С++ написать программу . Натуральное число называется числом Армстронга, если сумма цифр числа, возве-денных в N-ную степень (где N – количество цифр в числе) равна самому числу. Например, 153 = 13 + 53 + 33. Найдите все трёхзначные Армстронга.
Ответы на вопрос
Ответил petyaGavrikov
0
#include <iostream>
using namespace std;
int main()
{
int n,s;
for (int i=100; i<=999; i++)
{
n = i % 10;
s = n*n*n;
n = i / 10 % 10;
s = s+n*n*n;
n = i /100;
s = s+n*n*n;
if (i == s) cout << i << "n";
}
return 0;
}
Результат:
153
370
371
407
using namespace std;
int main()
{
int n,s;
for (int i=100; i<=999; i++)
{
n = i % 10;
s = n*n*n;
n = i / 10 % 10;
s = s+n*n*n;
n = i /100;
s = s+n*n*n;
if (i == s) cout << i << "n";
}
return 0;
}
Результат:
153
370
371
407
Ответил tanyalove23
0
Спасибо за помощь)
Новые вопросы