Информатика, вопрос задал Humansman , 1 год назад

На языке Python.Срочно пожалуйста.Метод строки isdigit() проверяет, состоит ли строка только из цифр. Напишите программу, которая запрашивает ввод двух целых чисел и выводит их сумму. В случае некорректного ввода программа не должна завершаться с ошибкой, а должна продолжать запрашивать числа.

Ответы на вопрос

Ответил TheEpic73
1

while True:

   number_1 = input('Введите число 1: ')

   if number_1.isdigit():

       break

while True:

   number_2 = input('Введите число 2: ')

   if number_2.isdigit():

       break

print('Сумма чисел ' + number_1 + " и " + number_2 + " = " + str(int(number_1) + int(number_2)))

Новые вопросы