Информатика, вопрос задал алька5 , 10 лет назад

на языке программирования Паскаль составить программу суммы нахождения суммы вводимых с клавиатуры  положительных чисел . Печать результата по вводу  0 ( используя цикл while  т.е. предусловие ).

Ответы на вопрос

Ответил sansanic
0

var

 a, s: real; //a - вводимое с клавиатуры число, s - сумма чисел

 

begin

  a:= 1;  //Присваиваем начальное значение, чтобы цикл выполнился

  s:= 0;

  while a <> 0 do   

  begin

    writeln('Введите положительное число');

    readln(a);

    if a < 0 then

    begin

      writeln('Введено не положительное число. Повторите ввод заново');

      continue; {Если а - не положительное число, вводим число заново}

    end;

    s:= s + a;

  end;

  writeln('Сумма:  ', s);  //Выводим сумму

end.

  

Новые вопросы