Информатика, вопрос задал Vollgraff , 8 лет назад

На языке программирования Паскаль напишите программу, которая:

1) В последовательности чисел находит количество чисел, кратных 3.
2) В последовательности чисел находит максимальное четное число, оканчивающееся на 4.

Ответы на вопрос

Ответил jeszthe
0
1)
program kr3sum;
var i,s.h:integer;
begin 
read(k) //кол чисел 
for i:=1 to k do begin 
read(h) //число для действий 
if h mod 3 = 0 then begin s:=s+1;
end;
writeln(s);
end.
2)
program jeje; 
var k,i,m,s,h:integer;
begin m:=0;
read(k);//кол-во чисел
for i:=1 to k do begin
readln(h);
if h mod 10 = 4 then begin s:=h;
            if s > m then m:=s                       
   end;
end;
write(m);
end.
Ответил jeszthe
0
2) проверка условия на четность не обязательна т.к число которое оканчивающейся на 4 и так четное
Ответил jeszthe
0
если необходимо то if (h div 10 = 4) and ( h mod 2 = 0) then...
Ответил jeszthe
0
если необходимо то if (h mod 10 = 4) and ( h mod 2 = 0) then... !!
Новые вопросы