Информатика, вопрос задал aksleonomeonom , 1 год назад

На языке Payton. Составить программу, которая печатает таблицу умножения и сложения натуральных чисел в десятичной системе. На языке Payton​

Ответы на вопрос

Ответил xokyno
0

def multiplication_table(n):

   print("Таблица умножения:")

   print("  |", end="")

   for i in range(1, n+1):

       print(f" {i:2}", end="")

   print("\n--+--" + "---"*n)

   for i in range(1, n+1):

       print(f"{i:2}|", end="")

       for j in range(1, n+1):

           result = i * j

           print(f" {result:2}", end="")

       print()

def addition_table(n):

   print("Таблица сложения:")

   print("  |", end="")

   for i in range(1, n+1):

       print(f" {i:2}", end="")

   print("\n--+--" + "---"*n)

   for i in range(1, n+1):

       print(f"{i:2}|", end="")

       for j in range(1, n+1):

           result = i + j

           print(f" {result:2}", end="")

       print()

n = 10

multiplication_table(n)

print()

addition_table(n)

Приложения:

aksleonomeonom: это пайтон?
xokyno: да
aksleonomeonom: а почему фигурные скобки?
aksleonomeonom: какой предмет?
Новые вопросы