На языке паскаль абс написать программу (Не глушилку , а нормальную программу)(желательно с помощью Циклов и If-ов)
Натуральное число называется совершенным, если оно равно сумме своих делителей, включая 1 и, естественно, исключая само число. Например, совершенным является число 6 (6=1+2+3).
Необходимо найти все совершенные числа, меньшие заданного числа N.
Формат входных данных
Вводится одно целое число N (1≤N≤100000).
Формат выходных данных
Требуется вывести все совершенные числа, меньшие заданного числа N.
Числа следует выводить в порядке возрастания, разделяя пробелами.
Примеры
входные данные выходные данные
7 6
Ответы на вопрос
Ответил Аноним
0
Ну Хьюстон почти все уже сделал. Я чуток подправил
var i,j,s,n:integer;
begin
readln(n);
for i := 1 to n-1 do
begin
s:=0;
for j := 1 to (i div 2) do
if i mod j=0 then s:=s+j;
if s=i then write(i,' ');
end;
end.
var i,j,s,n:integer;
begin
readln(n);
for i := 1 to n-1 do
begin
s:=0;
for j := 1 to (i div 2) do
if i mod j=0 then s:=s+j;
if s=i then write(i,' ');
end;
end.
Новые вопросы
География,
2 года назад
Физика,
2 года назад
Алгебра,
9 лет назад
Биология,
9 лет назад
Математика,
10 лет назад