Информатика, вопрос задал bodyashafarenko , 1 год назад

На входе программы имеется натуральное число n (n > 99). В числе n нужно обменять местами цифры сотен и единиц.
Входные данные #1
512
Выходные данные #1
215
Программа для паскаля!!

Ответы на вопрос

Ответил lingvini2013
1

var

 n: integer;

begin

 readln(n);

 writeln((n div 1000) * 1000 + (n mod 1000 mod 10) * 100 + (n mod 1000 mod 100 div 10) * 10 + (n mod 1000 div 100))

end.


bodyashafarenko: var только с n
bodyashafarenko: и всё в одном примере
lingvini2013: Исправил
bodyashafarenko: чёрт, всё верно, но решение не засчитывает((
bodyashafarenko: чёртов e-olymp
SpitefulSpamer: Потому что неправильно..
SpitefulSpamer: 123
123321
lingvini2013: Нашёл перепутанный mod/div, у меня теперь работает
bodyashafarenko: А сделаешь чтобы вышло 152?
bodyashafarenko: ))
Новые вопросы