Информатика, вопрос задал kpsxgod8303 , 2 года назад

На вход программы поступает последовательность из N неотрицательных целых чисел, каждое из которых не больше 1000. Требуется определить, какая сумма цифр чаще всего встречается среди этих чисел. Если таких значений несколько, необходимо вывести наибольшее из них.
Входные данные:
На вход программе подаётся натуральное число N (N<= 1000), а затем N натуральных чисел, каждое из которых не превышает 1000.
Пример входных данных:
3
13
22
32
Выходные данные:
Программа должна вывести наибольшую сумму цифр, которая чаще всего встречается среди введённых чисел.
Пример выходных данных для приведённого примера входных данных:
4
Два числа имеют сумму цифр 4.
Паскаль ABC

Ответы на вопрос

Ответил вооолк
1
егэ:)

var N, x, sum, maxi, i:integer;
a:array [0..27] of integer;
begin
readln(N);
sum:=0;
for i:=1 to N do beginreadln(x);
while x>0 do beginsum:=sum+x mod 10;x:=x div 10;end;a[sum]:=a[sum]+1;sum:=0;end;
for i:=0 to 27 doif a[i]>maxi then maxi:=i;
writeln(maxi);end.
Приложения:
Новые вопросы