Информатика, вопрос задал Lol4exui , 1 год назад

На вход программе подаются два целых числа a и b(a≤b). Напишите программу, которая подсчитывает количество чисел в диапазоне от a до b включительно, куб которых оканчивается на 2 или 5.​

Ответы на вопрос

Ответил Аноним
1

def main():

 # Читаем введенные числа

 a = int(input())

 b = int(input())

 # Переменная для хранения результата

 result = 0

 # Перебираем числа в диапазоне [a, b]

 for i in range(a, b+1):

   # Вычисляем куб числа

   cube = i ** 3

   # Проверяем, оканчивается ли куб числа на 2 или 5

   if cube % 10 in [2, 5]:

     # Если да, увеличиваем результат на 1

     result += 1

 # Выводим результат

 print(result)

# Запускаем программу

main()


Эта программа читает два целых числа a и b с помощью функции input, а затем перебирает числа в диапазоне от a до b включительно с помощью цикла for. Для каждого числа в цикле вычисляется куб с помощью оператора возведения в степень **, а затем проверяется, оканчивается ли куб числа на 2 или 5 с помощью оператора взятия остатка от деления %

Новые вопросы