Информатика, вопрос задал 1234564090 , 7 лет назад

На вход программе подается список натуральных чисел. Напишите программу нахождения количества чисел, кратных 5, но не кратных 3.
phyton, помогите плиз

Ответы на вопрос

Ответил badnsnus
0

Ответ: список вводится через запятую

a = input()

s = []

snow = ''

while len(a) > 0:

   if a[0] != ',':

       if len(a) != 1:

           snow = snow + a[0]

           a = a[1:]

       else:

           snow = snow + a[0]

           s.append(int(snow))

           a = a[1:]

   else:

       s.append(int(snow))

       snow = ''

       a = a[1:]

c = 0

for i in range(len(s)):

   if s[i] % 5 == 0 and s[i] % 3 != 0:

       c += 1

print(c)

Новые вопросы