Информатика, вопрос задал 1234564090 , 7 лет назад

На вход программе подается список целых чисел. Используя любой алгоритм сортировки (пузырьком или камнем) найдите 3 наибольших элемента списка. Выведите эти элементы в любом порядке
phyton, помогите плиз

Ответы на вопрос

Ответил badnsnus
0

Ответ:  список целых чисел - вводится через запятую

a = input()

s = []

snow = ''

while len(a) > 0:

   if a[0] != ',':

       if len(a) != 1:

           snow = snow + a[0]

           a = a[1:]

       else:

           snow = snow + a[0]

           s.append(int(snow))

           a = a[1:]

   else:

       s.append(int(snow))

       snow = ''

       a = a[1:]

s.sort()

s = list(reversed(s))

print(s[0], s[1], s[2])

Новые вопросы