Информатика, вопрос задал mashazvezda123456789 , 7 лет назад

на с++ с циклом white
На вход программы подается 10 чисел. Выведите в столбик для каждого из них число, равное удвоенному квадрату первоначального числа.


Формат входных данных

В единственной строке через пробел вводятся 10 целых чисел, по модулю не превосходящих 1000.

Формат выходных данных

Необходимо вывести 10 строк, в каждой из которых будет по одному числу — результат преобразования исходных чисел.

Примеры

входные данные выходные данные

1 10 2 4 2 5 3 6 101 11

2

200

8

32

8

50

18

72

20402

242

Ответы на вопрос

Ответил csharp
0
  • Прикреплена фотография с кодом, тест и сам код
  • Открывать любым текстовым редактором
Приложения:
Ответил DexelGamer
0
В задании просили дать решение через whi(l?)e
Ответил csharp
0
Спасибо.
Ответил DexelGamer
0

Решение с массивами

#include <bits/stdc++.h>

using namespace std;

int main() {

   int a[10];

   int i = 0;

   while (i < 10) {

     cin >> a[i];

     ++i;

   }

   i = 0;

   while (i < 10) {

     cout << (2 * a[i] * a[i]) << endl;

     ++i;

   }

   return 0;

}


Решение без массивов (онлайн-вывод)

#include <bits/stdc++.h>

using namespace std;

int main() {

   int x;

   int i = 0;

   while (i < 10) {

     cin >> x;

     cout << (2 * x * x) << endl;

     ++i;

   }

   return 0;

}


Приложения:
Новые вопросы