Информатика, вопрос задал fadeylit01 , 7 лет назад

НА С++ НЕ НА ПИТОНЕ НЕ НА ПАСКАЛЕ, НА С++ СРОЧНО!!!!!!!!!!!!!!!!!!!!!

За многие годы заточения узник замка Иф проделал в стене прямоугольное отверстие размером D×E. Замок Иф сложен из кирпичей размером A×B×C. Определите, сможет ли узник выбрасывать кирпичи в море через это отверстие, если стороны кирпича должны быть параллельны сторонам отверстия.

Входные данные

Программа получает на вход числа A, B, C, D, E. Все числа натуральные, не превосходящие 10000.

Выходные данные

Программа должна вывести слово YES или NO.

Sample Input:

1
1
1
1
1
Sample Output:

Ответы на вопрос

Ответил settom
3

Ответ:

#include <iostream>

using namespace std;

int main()

{

   int A,B,C,D,E;

   int HoleW=0,HoleH=0; // Ширина и высота дырки, размеры относятся друг к друку так: высота <= ширина <= длина

   int BrickW=0,BrickH=0; // Ширина и высота кирпича (минимальные геометрические его размеры)

   cin >> A >> B >> C >> D >> E ;

   

   //Задаём размеры дырки

   if(D>E) {HoleW = D; HoleH = E;}

   else {HoleW = E; HoleH = D;}

   

   cout << "Hole W=" << HoleW << " H=" << HoleH << "\n";

   

   //Задаём размер кирпича (эту часть конечно можно сделать более изящно, но лень)

   if(A<=B && A<=C ) {

       BrickH = A;

       if(B<C) BrickW = B;

       else BrickW = C;

   }

   

   if(B<=A && B<=C ) {

       BrickH = B;

       if(A<C) BrickW = A;

       else BrickW = C;

   }

   

   if(C<=A && C<=B ) {

       BrickH = C;

       if(A<B) BrickW = A;

       else BrickW = B;

   }

   

   cout << "Brick W=" << BrickW << " H=" << BrickH << "\n";

   

   //Сравниваем размеры дырки и кирпича

   if(BrickW<=HoleW && BrickH<=HoleH) cout << "YES";

   else cout << "NO";

   

   return 0;

}

Новые вопросы