На с++
Напишите программу, которая находит в массиве количество элементов, равных заданному значению X .
Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. В третьей строке записано число X . Гарантируется, что 0 < N ≤ 10000 .
Выходные данные
Программа должна вывести одно числа – количество элементов массива, равных X .
Примеры
входные данные
6
1 2 3 2 3 3
2
выходные данные
2
Ответы на вопрос
Ответил clinteastwood2
0
//g++ 5.4.0
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int main()
{
size_t N, num;
cin >> N >> num;
vector<int> a(N);
for (size_t i = 0; i < N; ++i)
cin >> a[i];
cout << count(a.begin(), a.end(), num);
}
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int main()
{
size_t N, num;
cin >> N >> num;
vector<int> a(N);
for (size_t i = 0; i < N; ++i)
cin >> a[i];
cout << count(a.begin(), a.end(), num);
}
Трафальгар:
не верно работает
Новые вопросы
Английский язык,
1 год назад
Окружающий мир,
1 год назад
Математика,
2 года назад
Русский язык,
2 года назад
Геометрия,
7 лет назад