Информатика, вопрос задал bulldoo , 2 года назад

(На с++)Написать программу. Подсчет нулевых элементов в заданном одномерном массиве.

Ответы на вопрос

Ответил MissKa
4
using namespase std;

void main ()
{
setlocale (LC_ALL, "Russian");
int n, k;\\размер массива и счетчик

cout << "Введите количество элементов массива" << endl;
cin >> n;
float *arr = new float[n]; \\создаем динамический массив, т.к. не знаем сколько дано элементов и какие они

\\заполнение массива с клавиатуры
for (int i=0; i<n; i++)
{
cout << "Введите " << i << "-ый элемент массива" << endl;
cin >> arr[i];
}

\\вывод массива на экран
for (int i=0; i<n; i++) cout << arr[i] << " " ;

\\подсчет нулевых элементов
k=0;
for (int i=0; i<n; i++)
{
if (arr[i] == 0) k++
}

cout << "Количество нулевых элементов в заданном массиве = " << k;
}


Новые вопросы