Информатика, вопрос задал gggggggggggggg4018 , 1 год назад

На Python
Задача 1
Напишите программу, которая по введенному пользователем числу, от 1 до 12, будет выводить на экран сообщение в виде названия месяца и времени года, Если пользователь введет недопустимое число, программа должна выдавать сообщение об ошибке.
Задача N°2.
Определить четверть координатной плоскости, которой принадлежит точка А(х, У).
Координаты точки ввести с клавиатуры
Задача N°3.
Напишите программу, которая будет проверять пользователя на умение перемножать однозначное натуральное число на двузначное, запрашивая ввод ответа с клавиатуры.
Результат проверки ответа пользователя должен выводиться на экран в виде соответствующего сообщения. В случае неправильного ответа, программа должна выводить сообщение об ошибке, дополнительно сообщая пользователю верный результат

Ответы на вопрос

Ответил DK404
1

Ответ:

Ex #1:

                                                                                   

n = int(input("Enter number.\n>>     "))

m = ["January", "February", "March", "April", "May", "June", "July", "August", "September", "October", "November", "December"]

print(m[n-1] if n<=12 and n>=1 else "Value error: n must be less 13 and bigger than 0.")

                                                                                   

Ex #2:

                                                                                   

x,y = map(float,input("Enter x and y with spaces,\n>>     ").split())

print("I part" if x>0 and y>0 else "II part" if x<0 and y>0 else "III part" if x<0 and y<0 else "IV part")

                                                                                   

Ex #3:

                                                                                   

from random import randint as rint

while 1:

    n1 = rint(1,9)

    n2 = rint(10,99)

    result = n1*n2

    print(f"{n1} * {n2} = ?")

    pend_out = float(input("Enter answer.\n>>     "))

    print("Correct!" if pend_out == result else f"Not correct. = (\nCorrect answer is {result}.")

                                                                                   

Объяснение:

Надеюсь что помоглa.


p15: выводить на экран сообщение в виде названия месяца и времени года
Новые вопросы