Информатика, вопрос задал feandry07 , 1 год назад

На Python

Создайте пустой список
Спросить у пользователя, сколько чисел он желает добавить в список.

Если он ввел значения меньше 0 или 0 выдать сообщение об ошибке.

Иначе:

• Спросить у пользователя значение каждого числа (организовать цикл

для этого)

• Добавить новый элемент в конец списка

• Вывести состояние списка после добавления.

• После заполнения списка вывести только положительные числа из

списка, например, если пользователь ввел -1 2 4 -9 6, то вывести 2 4 6

Ответы на вопрос

Ответил salpsx
0

Ответ:

numbers = []

n = int(input("Сколько чисел вы хотите добавить в список? "))

if n <= 0:

   print("Ошибка: число должно быть больше 0")

else:

   for i in range(n):

       num = int(input(f"Введите число {i+1}: "))

       numbers.append(num)

   print("Состояние списка:", numbers)

   positive_numbers = [num for num in numbers if num > 0]

   print("Положительные числа из списка:", positive_numbers)

Объяснение:

Программа создает пустой список numbers. Затем она запрашивает у пользователя количество чисел, которые он хочет добавить в список. Если пользователь вводит число, которое меньше или равно нулю, программа выводит сообщение об ошибке. Если пользователь вводит корректное число, программа запускает цикл, который запрашивает у пользователя значение каждого числа и добавляет его в конец списка numbers. После добавления новых элементов программа выводит состояние списка и создает новый список positive_numbers, который содержит только положительные числа из списка numbers. В конце программа выводит список positive_numbers.

Новые вопросы