Информатика, вопрос задал arseniy7159 , 2 года назад

На PYTHON; Составьте программу для возведения любого числа в любую натуральную степень используя цикл FOR​

Ответы на вопрос

Ответил Lyavontiy
0

Ответ:

p = int(input("Показатель степени: "))

n = int(input("Предел: "))

i = 1

while i ** p <= n:

   print(i ** p, end=' ')

   i += 1

print("\nПоследнее число,"

     " возведенное в степень:", i - 1)

Объяснение:


arseniy7159: очень умно списать, спасибо
arseniy7159: и это не то кста
Ответил nastikots
6

Ответ:

a = int(input("Введите число "))

c = int(input("Введите степень "))

s = 1

for i in range(c):

   s = s * a

print(s)


arseniy7159: спасибо
Новые вопросы