Информатика, вопрос задал arseniy7159 , 2 года назад

На Python Составьте программу для решения следующей задачи:

Клиент кладет в банк сумму Х, под процент P. Сколько у него будет через N лет, если каждый год он будет снимать со счета сумму K​

Ответы на вопрос

Ответил nktselepov
1

N = float(input('Кол-во лет: '))

P = float(input('Кол-во процентов: '))

X = float(input('Сумма на счету: '))

K = float(input('Сумма снятия в год: '))

for i in range(int(N)):

   X = ( X + X * (P/100)) - K

print(f'Через {int(N)} лет у тебя будет целых {X} рублей, хватит на мороженое и дошик.')

Держи. Если я не накосячил нигде, то это верная прога. Проверь в питоне с числами


arseniy7159: ♥️
nktselepov: стоп, нет. где-то ошибка
arseniy7159: Ага, ищу где
nktselepov: скорее всего в самой формуле
nktselepov: а, я дурак. сейчас изменю
nktselepov: всё, проверь. сейчас должно быть верно. немного ереписаол
nktselepov: переписал*
Новые вопросы