НА ПАСКАЛЕЕЕЕЕЕЕЕЕЕ
3. Напишите программу, которая заполняет массив из 20 элементов случайными числами на
отрезке [0; 200) и считает количество элементов, которые не делятся на 10.
Ответы на вопрос
Ответ:
program CountNonDivisibleByTen;
const
arraySize = 20;
var
numbers: array[1..arraySize] of integer;
countNonDivisibleByTen: integer;
i: integer;
begin
// Инициализация генератора случайных чисел
Randomize;
// Заполнение массива случайными числами
for i := 1 to arraySize do
begin
numbers[i] := Random(200); // Генерация чисел в диапазоне [0; 199]
Write(numbers[i], ' '); // Вывод элементов массива для наглядности
end;
// Подсчет количества элементов, не делящихся на 10
countNonDivisibleByTen := 0;
for i := 1 to arraySize do
begin
if (numbers[i] mod 10 <> 0) then
Inc(countNonDivisibleByTen);
end;
Writeln;
Writeln('Количество элементов, не делящихся на 10: ', countNonDivisibleByTen);
Readln;
end.
Объяснение:
Программа создает массив из 20 элементов, заполняет его случайными числами в диапазоне [0; 199] с помощью функции Random(200). Затем она проходит по массиву и подсчитывает количество элементов, которые не делятся на 10 (проверяется с помощью оператора mod). Результат выводится на экран.
Задача решается в одну строчку.
## ArrRandom(20, 0, 199).Println.Count(n -> n mod 10 <> 0).Print
