на паскале составить программу нахождения наибольшего общего делителя трех чисел , испол. след. формулу: НОД(А,В,С)=НОД(НОД(А,В),С)
Ответы на вопрос
Ответил Farixy
0
function NOD (x,y:longint):longint;
begin
if x=0 then NOD:=y
else
if y=0 then NOD:=x
else
if x>y then NOD:=NOD(x mod y,y)
else
NOD:=NOD(x,y mod x);
end;
var
a,b,c:longint;
begin
read(a,b,c);
writeln('NOD (',a,',',b,',',c,') = ',NOD(NOD(a,b),c));
end.
Новые вопросы