На экран введено двузначное число. Составьте программу для вычисления, четная или нет сумма его цифр. ЯЗЫК C++
Ответы на вопрос
Ответил Сорин
0
Вот код для твоего задания:
#include <iostream>
int main() {
std::cout << "Введите двузначное число: ";
int userNumber;
std::cin >> userNumber;
if (userNumber >= 10 && userNumber <= 99) {
int sumOfDigits = userNumber % 10 + userNumber / 10;
std::cout << "Сумма цифр вашего числа " << (sumOfDigits % 2 == 0 ? "четная." : "нечетная.") << std::endl;
} else {
std::cout << "Пожалуйста, введите двузначное число." << std::endl;
}
return 0;
}
Новые вопросы