Информатика, вопрос задал ATAKAHACEPOBO , 7 лет назад

Может кто-нибудь помочь с задачей?

"3. Программа получает на вход последовательность из N целых неотрицательных чисел. Найти количество всех цифр в последовательности чисел.

Ввод данных:
N = 5
23 475 12 1 683"

Нужно решить на Питоне и с использованием цикла while. Понятие того, что можно сделать, есть, но в голову не приходит, как это написать. Буду благодарить вас за помощь столько, сколько хотите, но помощь сильно нужна. Спасибо заранее!

Ответы на вопрос

Ответил Аноним
0

N = int(input())

number_list = str(input()).split()

if len(number_list) != N:

   quit()

letter_list = []

for n in number_list:

   for i in n:

       letter_list.append(i)

amount = 0

for letter in letter_list:

   amount += int(letter)

print(letter_list)

print(amount)

забыл что нужно через while =(

Новые вопросы