Информатика, вопрос задал kirill36reg19 , 7 лет назад

Может кто написать программу для решения на паскале? ​

Приложения:

Ответы на вопрос

Ответил HeTempl
0

(На фото всё более понятно и в цвете)


Пояснение:

1)вводится переменная n. nдолжна быть четной. Чтобы n не была введена не четной используется repeat для запроса n, пока она не будет введена чётной.

2)идёт цикл от 1 до n. Каждый раз он просит ввести a i-тое, которое каждый раз записывается по-новой в переменную g. Далее она используется для изменения значения b и c.

3)выводится ответ, где b делим на c.

b-делимое, то есть "-a1-a3-...-a(n-1)"

c-делитель, то есть "а2+а4...+аn"


Код для копирования:



program school5;

Var i, n:integer;

b, c, g:real;

begin

Repeat

Write('Введите n (n-чётное)>> ');

ReadLn(n);

Until n mod 2 = 0;

For i:=1 to n do

Begin

Write('Введите a', i, '>> ');

ReadLn(g);

If i mod 2 <> 0 then

b:=b-g

Else c:=c+g;

End;

Write('ответ: ', b/c);

end.

Приложения:
Ответил HeTempl
0
Исправил в решение
Ответил HeTempl
0
Пояснение не требуется?
Ответил kirill36reg19
0
спасибо, ну если не трудно то можно.
Ответил HeTempl
0
Сделал
Ответил kirill36reg19
0
огромное спасибо
Новые вопросы