МНОГО БАЛЛОВ! Написать программу на языке Pacsal. Вот задача.
Пользователь вводит число и кол-во строк. На экран выводится указанное кол-во строк, в которых числа повторяются от 1 до кол-ва строк. Т.е. примерно так должно выйти. Вбиваем 5 4. Получаем "пирамидку":
5
55
555
5555
Ответы на вопрос
Ответил Студэнt
0
//FPC 2.6.4
var
n, count, i, j: integer;
begin
readln (n, count);
for i:=1 to count do
begin
for j:=1 to i do write(n);
writeln();
end;
end.
var
n, count, i, j: integer;
begin
readln (n, count);
for i:=1 to count do
begin
for j:=1 to i do write(n);
writeln();
end;
end.
Ответил Эпичный
0
У нас пока нет такого понятия как count и непонятное //FPC 2.6.4 . А как без этого обойтись?
Ответил Студэнt
0
Начнем по порядку:
Ответил Студэнt
0
1) Count - всего лишь обозначение переменной, в которую мы запомним, сколько строк всего нам нужно вывести (можешь поменять на любой другой идентификатор)
Ответил Студэнt
0
2) FPC - Free Pascal, версия языка - 2.6.4 Это я написал для того, чтобы подчеркнуть, что данную прогу ты можешь вставить в любой компилятор Pascal`я, и он ее "поймет"
Ответил Студэнt
0
Просто убери
Новые вопросы