Информатика, вопрос задал loktaevamariya , 2 года назад

Минимум-Максимум.
На вход программе подается последовательность целых чисел,заканчивающаяся 0.Видитет минимальное и максимальное значение среди чисел этой последовательности,0 при этом не учитывается.При решении задачи массив использовать нельзя.

Ответы на вопрос

Ответил hardmad
3
var max, min, x:real;
begin
max:=-32001;
min:=32001;
readln(x);
while x<>0 do begin
if x > max then
max:=x;
if x < min then
min:=x;
readln(x);end;
write(max,min);
readln
end.
Новые вопросы