Массивы. Информатика). 10 класс
http://informatics.mccme.ru/mod/statements/view3.php?id=11223&chapterid=112271#1 на данном сайте задали решить следующую задачу:
Напишите программу, которая заполняет массив из N элементов членами арифметической прогрессии с начальным значением X и разностью D .
Входные данные
Входная строка содержит три целых числа: начальное значение X , разность D и размер массива N , разделённые пробелом. Гарантируется, что 0 < N ≤ 10000 .
Выходные данные
Программа должна вывести содержимое массива: N первых членов арифметической прогрессии с начальным значением X и разностью D .
Примеры
входные данные
8 4 5
выходные данные
8 12 16 20 24
эту задачу нужно решить на 100 баллов, чтобы высветилось ОК, а у меня частичное решение. Подскажите пожалуйста, что у меня не так
Вот мое решение:
Var A:array[1..10000] of integer;
i,x,d,n:integer;
Begin
readln(x,d,n);
A[n]:=x;
For i:=n-1 downto 1 do
A[i]:=A[i+1]+d;
for i:=n downto 1 do
write(a[i],' ');
End.
Заранее спасибо:)
На этот вопрос еще никто не ответил. Напишите свой ответ или воспользуйтесь поиском:
Новые вопросы